Partial Upgrades in Ubuntu + Docky issue [FIXED]


One day out of the blue Ubuntu said it needed a partial upgrade, I clicked OK and didn't think twice about it, it did some work on many packages and for some reason Docky 3.0 (Experimental branch by Rictoz) was selected for “upgrade” and after the reboot it was gone!

 
The partial upgrade in general is nothing to worry about and it's safe to click continue, especially I'm running 14.04 LTS which is supposedly supported until late 2016.
Partial upgrade
I was set back to Docky 2.0.2 which I don't have a problem with, except it crashes.
(If you read my Docky post you know that I chose Docky 3.0 over 2.0.2 because it's more stable and doesn't crash randomly all the time. Despite Docky 2.0.2 having cool “Docklets” that added to it's functionality.)
 I couldn't install Docky 3.0 due to package dependency issues, and therefore I was stuck with Docky 2.0.2 for a while, only then I realized how much I depended on it to get my things done!

The fix was super easy!

I went to the downloaded files I had which were three files: Docky, Libplank, and Libplank common.
Using Gdebi I installed Libplank common the first, then Libplank and finally Docky 3.0, it replaces the old one and no need to uninstall.
Thing is every time it looks for updates it wants to remove Docky, and that happens daily, I found a

way to fix that by simply “locking” the version.
I went to Synaptic and searched for Docky, selected it and clicked lock version under package. Now even when it looks for updates it greys out Docky and doesn't update it. I have a detailed tutorial on how to use Synaptic that you can find here.

Locking package version using Synaptic


That's how I got Docky 3.0 back after it was ruined by the partial upgrade, I hope you found this useful, please let me hear your feedback and have a nice day.

Comments